[libcxx-commits] [PATCH] D113906: [libc++] [test] Add "robust_re_difference_type.compile.pass.cpp" for all the algorithms.

Louis Dionne via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Nov 16 08:07:02 PST 2021


ldionne accepted this revision as: ldionne.
ldionne added a comment.

LGTM despite some suggestions.



================
Comment at: libcxx/test/std/algorithms/robust_against_adl.compile.pass.cpp:22
+template<class>
+struct Intable {
+    TEST_CONSTEXPR operator int() const { return 1; }
----------------
Quuxplusone wrote:
> philnik wrote:
> > I think a better name would be `ConvertibleToInt`.
> Veto; sure it's only used once in the whole file, but still I see no reason to make the name longer and more technical.
Honestly, `Intable` is a poor name IMO. I would actually do:

```
template <class T>
struct ConvertibleTo { TEST_CONSTEXPR operator T() const { return T(); } };
```


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D113906/new/

https://reviews.llvm.org/D113906



More information about the libcxx-commits mailing list