[libcxx-commits] [PATCH] D99913: [SystemZ][z/OS] Modify cxxabi to be compatible with existing z/OS runtime
Zibi Sarbino via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Wed May 5 06:50:35 PDT 2021
zibi added inline comments.
================
Comment at: libcxxabi/include/zos/unwind.h:1
+#ifndef _UNWIND_H
+#define _UNWIND_H
----------------
Please add the copyright statement.
================
Comment at: libcxxabi/include/zos/unwind.h:48
+
+void _Unwind_SetGR (struct _Unwind_Context *context, int index, uint64_t new_value);
+uintptr_t _Unwind_GetGR (void *context, int index);
----------------
I see you use `context` as parameter name for some functions and ctx` for others. Perhaps you can make this consistent for readability.
================
Comment at: libcxxabi/include/zos/unwind.h:53
+void* _Unwind_GetLandingPad(void *ctx);
+void _Unwind_SetLandingPad(void *ctx, void *landingpad);
+void *_Unwind_GetExceptionAddress(void *ctx);
----------------
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99913/new/
https://reviews.llvm.org/D99913
More information about the libcxx-commits
mailing list