[libcxx-commits] [PATCH] D102135: [libcxx][ranges] adds _`copyable-box`_

Zoe Carver via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Wed Jun 23 11:20:23 PDT 2021


zoecarver accepted this revision as: zoecarver.
zoecarver added a comment.

This LGTM. Thanks.



================
Comment at: libcxx/test/libcxx/ranges/range.adaptors/range.copy.wrap/base.compile.pass.cpp:15
+
+#include <__ranges/copyable_box.h>
+
----------------
cjdb wrote:
> zoecarver wrote:
> > Hmm, I know this is a libc++ only test, but I still think maybe it should include ranges. (Same elsewhere.)
> `<ranges>` doesn't (and shouldn't) include this header, so we need to explicitly include it.
Hmm, maybe we should rename it, then. Or put it elsewhere... WDYT?


================
Comment at: libcxx/test/libcxx/ranges/range.adaptors/range.copy.wrap/properties.compile.pass.cpp:30
+
+struct not_copy_constructible {
+  not_copy_constructible() = default;
----------------
cjdb wrote:
> zoecarver wrote:
> > Can you rename this to `move_only` or something? 
> The current name spells out exactly what's missing. `move_only` implies copy-assignment is false.
Sorry I misread the name on the first go around. This is good with me.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D102135/new/

https://reviews.llvm.org/D102135



More information about the libcxx-commits mailing list