[libcxx-commits] [PATCH] D106735: [libc++] Fix signed overflow inside ranges::advance.
Christopher Di Bella via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Mon Jul 26 11:27:01 PDT 2021
cjdb added inline comments.
================
Comment at: libcxx/test/std/iterators/iterator.primitives/range.iter.ops/range.iter.ops.advance/iterator_count_sentinel.pass.cpp:104
+struct Iota {
+ using difference_type = int;
----------------
Quuxplusone wrote:
> cjdb wrote:
> > Please match the naming conventions that the file uses.
> Got any suggestions? The "naming convention" in this file seems no more than "something long with lots of underscores."
I'm fine with just `iota`, but if you want something "more", perhaps `iota_range`, or `iota_range_regression`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D106735/new/
https://reviews.llvm.org/D106735
More information about the libcxx-commits
mailing list