[libcxx-commits] [PATCH] D93186: [libc++abi] Simplify __gxx_personality_v0

Louis Dionne via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Thu Jan 7 11:54:13 PST 2021


ldionne added a comment.

So, just to clarify because I'm really not familiar with this code -- this is supposed to be a NFC change, right? My understanding so far is that this doesn't change functionality, but I'd like to confirm. Also, do you know someone else that knows this code and can give a good review?



================
Comment at: libcxxabi/src/cxa_personality.cpp:969
+        // Reload the results from the phase 1 cache.
+        auto* exception_header = (__cxa_exception*)(unwind_exception + 1) - 1;
+        results.ttypeIndex = exception_header->handlerSwitchValue;
----------------
I don't think it hurts readability to leave it as `__cxa_exception* exception_header`, despite the cast.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D93186/new/

https://reviews.llvm.org/D93186



More information about the libcxx-commits mailing list