[libcxx-commits] [PATCH] D108144: [libc++] Introduce _LIBCPP_EXPRESSION_EQUIVALENT

Louis Dionne via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Aug 17 07:21:21 PDT 2021


ldionne added a comment.

In D108144#2948132 <https://reviews.llvm.org/D108144#2948132>, @mclow.lists wrote:

> There's also all the ones in __functional/operations.h, like `greater_equal<void>`

Thanks, fixed.

As I said, I'm not attached to this patch. In fact, I'm also not sure it increases readability. So instead, for now, I'll just make all the instances of this pattern consistent without using a macro.

Mostly for posterity: if we want to make this change in the future, we can do something like this: `sed -i '' -E 's/(\s*)noexcept\(noexcept\((.+)\)\)\n\1-> decltype\(      \2\)\n\1\{ return          \2; \}/\1_LIBCPP_EXPRESSION_EQUIVALENT(\2)/g' $(find libcxx/include -type f)` (except that `sed` doesn't match across lines).


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D108144/new/

https://reviews.llvm.org/D108144



More information about the libcxx-commits mailing list