[libcxx-commits] [PATCH] D100255: [libcxx][ranges] adds `range` access CPOs

Zoe Carver via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Wed Apr 28 15:10:39 PDT 2021


zoecarver added inline comments.


================
Comment at: libcxx/include/__ranges/begin.h:88
+
+    void operator()(auto&&) const = delete;
+  };
----------------
ldionne wrote:
> What is the purpose of that overload?
It's supposed to make the error message easier to read. I had it in an earlier version of `ranges::size` but decided to remove it after some discussion: https://reviews.llvm.org/D101079#inline-953328

Here's a gist I made for the difference in error messages for `ranges::size`: https://gist.github.com/zoecarver/594015f42664e3daa7ab7c3978027682

The `ranges::begin` errors may look different, though. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D100255/new/

https://reviews.llvm.org/D100255



More information about the libcxx-commits mailing list