[libcxx-commits] [PATCH] D74292: [libcxx] adds [concept.derived]
Christopher Di Bella via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Tue Sep 22 17:55:51 PDT 2020
cjdb added inline comments.
================
Comment at: libcxx/test/std/concepts/lang/derived_from.pass.cpp:22
+
+struct Base2 : private Base1 {};
+struct Derived3 : Base2 {};
----------------
miscco wrote:
> I would suggest a better name maybe `Derived_private` and `Derived_public` instead of Derived1/Base2 same for protected
>
>
Done.
================
Comment at: libcxx/test/std/concepts/lang/derived_from.pass.cpp:152
+ }
+
+ // From as the return type of a pointer-to-function
----------------
miscco wrote:
> That newline is not consistent with the other sections. That said i personally prefer a newline here.
Newline is because of the comment.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74292/new/
https://reviews.llvm.org/D74292
More information about the libcxx-commits
mailing list