[libcxx-commits] [PATCH] D77786: [AArch64] Add v8.5 Branch Target Identification support.
Fangrui Song via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Tue Apr 14 15:45:51 PDT 2020
MaskRay added a comment.
Mostly good apart from the renaming issue and a nit about comments. I have some patches in the BTI/PAC area, so I am confident.
================
Comment at: libunwind/src/assembly.h:47
+#elif (defined(__arm64__) || defined(__aarch64__)) && defined(__ARM_FEATURE_BTI_DEFAULT)
+#define PPC64_OPD1 \
+ .pushsection ".note.gnu.property", "a" SEPARATOR \
----------------
danielkiss wrote:
> chill wrote:
> > This will be emitted for all functions, but we need only one per object file, isn't it ?
> >
> > Also, could you, please, rename `PPC64OPD{1,2}` to `TARGET_OPD{1,2}`, or `{ARCH ...}`, something like that.
> >
> Yes, only one function per file today, but let's add the section per include.
>
> Rename is done.
@chill
Please don't rename OPD{1,2}. They are really specific to PowerPC ELFv1 function descriptors. No other architecture needs them.
================
Comment at: libunwind/src/assembly.h:53
+ .asciz "GNU" SEPARATOR \
+ /* GNU_PROPERTY_AARCH64_FEATURE_1_AND */ \
+ .long 0xc0000000 SEPARATOR \
----------------
The comments can be added right after `.long`
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D77786/new/
https://reviews.llvm.org/D77786
More information about the libcxx-commits
mailing list