[Libclc-dev] Compilation problems on Slackware 14.2 32-bit

Zbigniew via Libclc-dev libclc-dev at lists.llvm.org
Mon Feb 5 13:37:09 PST 2018

On Mon, Feb 05, 2018 at 08:52:37PM +0100, Jeroen Ketema via Libclc-dev wrote:

> Hi Zbigniew,
> Thanks for your email. Could you please tell us how you ran configure.py?

It's run by Slackbuild script. The relevant part is:

  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
CFLAGS="$SLKCFLAGS -D__extern_always_inline=inline" \
./configure.py \
  --prefix=/usr \
  --libexecdir=/usr/lib$LIBDIRSUFFIX/clc/ \
  --pkgconfigdir=/usr/lib$LIBDIRSUFFIX/pkgconfig/ || exit 1

Well I managed to compile the library, but this is really painful process.

1. I had to modify generated Makefile, by adding there:

 -I/usr/include/c++/5.3.0/i586-slackware-linux -I/usr/include/c++/5.3.0

"configure" script was unable to find out the library will need header
files from both directories.

2. Next problem was, that some object files (crtbegin.o IIRC) from directory


...were also needed for linking stage.

Again: why "configure.py" is unable to detect their location? It's not that
difficult: "find /usr/lib -name crtbegin.o". Not being sure, how to pass
this information to Makefile, I simply copied all these object files from
that directory into libclc source directory. It seems, it worked.

3. Another problem - the one I contacted you with: it seems it's looking for
libgcc.o shared library, which SIMPLY DOESN'T EXIST in most distros! You can
choose among either:




So again I had to do "manual intervention" by adding a symlink, to complete
linking process: "ln -s /usr/lib/libgcc_s.so /usr/lib/libgcc.so". It seems
it worked, by until now I'm not sure is it exactly library meant to be
linked with libclc (similar name doesn't have mean it is). But I hope it is.

So finally I created the package, and even compiled Mesa which depends upon
it. It seems it also works.

More information about the Libclc-dev mailing list