[libc-commits] [PATCH] D149691: [libc] Add 'UNIT_TEST_ONLY' and 'HERMETIC_TEST_ONLY' to 'add_libc_test'
Siva Chandra via Phabricator via libc-commits
libc-commits at lists.llvm.org
Tue May 2 14:06:50 PDT 2023
sivachandra accepted this revision.
sivachandra added inline comments.
This revision is now accepted and ready to land.
================
Comment at: libc/test/src/string/memory_utils/CMakeLists.txt:1
-# This test uses too much memory to be made hermetic.
-add_libc_unittest(
+# This test currently uses too much memory to be made hermetic.
+add_libc_test(
----------------
Nit: "... to enable a hermetic test also."
================
Comment at: libc/test/src/string/memory_utils/CMakeLists.txt:18
libc.src.string.memory_utils.memory_utils
+ UNIT_TEST_ONLY
)
----------------
Nit: Move it right after the test name below line #3.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D149691/new/
https://reviews.llvm.org/D149691
More information about the libc-commits
mailing list