[libc-commits] [PATCH] D147054: [libc] Begin implementing a library for the RPC server
Joseph Huber via Phabricator via libc-commits
libc-commits at lists.llvm.org
Tue Jun 6 04:17:19 PDT 2023
jhuber6 marked 3 inline comments as done.
jhuber6 added inline comments.
================
Comment at: libc/utils/gpu/server/Server.h:46
+/// A function used to allocate \p size bytes.
+typedef void *(rpc_alloc_ty)(uint64_t size, void *data);
+
----------------
sivachandra wrote:
> Why are there separate functions allocation and deallocation?
I'll change the name to `free` but we need both to adequately de allocate the shared memory.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D147054/new/
https://reviews.llvm.org/D147054
More information about the libc-commits
mailing list