[libc-commits] [PATCH] D148069: [LIBC] Implement remainder of posix 'sched.h' minus `SCHED_SPORADIC`
Michael Jones via Phabricator via libc-commits
libc-commits at lists.llvm.org
Thu Apr 13 14:42:52 PDT 2023
michaelrj added a comment.
I think with these last few changes it should be good to go. I want to test it before it lands so I'll approve once that's done.
================
Comment at: libc/test/src/sched/get_priority_test.cpp:16
+
+TEST(LlvmLibcGetPriorityTest, HandleBadPolicyTest) {
+
----------------
Even if `sched` isn't in the filename, it should be in the test title since this is what shows up when you run the test. Same for the other tests.
================
Comment at: libc/test/src/sched/sched_rr_get_interval_test.cpp:38
+ // We can only set SCHED_RR with CAP_SYS_ADMIN
+ if (getuid() == 0)
+ SetSched(SCHED_RR);
----------------
for clarity, this should be `::getuid` since it's coming from the system's libc.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D148069/new/
https://reviews.llvm.org/D148069
More information about the libc-commits
mailing list