[libc-commits] [PATCH] D118954: [libc] add a vector internal class
Michael Jones via Phabricator via libc-commits
libc-commits at lists.llvm.org
Mon Feb 7 15:49:14 PST 2022
michaelrj added inline comments.
================
Comment at: libc/src/__support/CPP/CMakeLists.txt:14
+add_header_library(
+ cpp_with_malloc
+ HDRS
----------------
lntue wrote:
> cpp_vector?
I named it `cpp_with_malloc` to match `standalone_cpp` but I agree that for the moment `cpp_vector` is a better name.
================
Comment at: libc/src/__support/CPP/vector.h:20
+
+void simple_memset(void *dst, char value, size_t count) {
+ char *data_array = static_cast<char *>(dst);
----------------
lntue wrote:
> lntue wrote:
> > you'll need static inline for this to avoid multiple definitions / linking problems as it is defined in a header file.
> Also is this being used anywhere? It doesn't look like to be with vector class?
Not anymore, I forgot to remove it when I removed the `clear` function.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D118954/new/
https://reviews.llvm.org/D118954
More information about the libc-commits
mailing list