[libc-commits] [PATCH] D140078: [libc] Handle allocation failures in the dirent API gracefully.
Siva Chandra via Phabricator via libc-commits
libc-commits at lists.llvm.org
Thu Dec 15 12:05:31 PST 2022
sivachandra added inline comments.
================
Comment at: libc/src/__support/CPP/CMakeLists.txt:105
+add_object_library(
+ new
+ SRCS
----------------
lntue wrote:
> sivachandra wrote:
> > lntue wrote:
> > > Maybe change the name to `new_and_delete` or `new_delete`?
> > The target names here reflect the header file name. So, I am inclined to keep it as is for the sake of consistency.
> Yes, that's actually what I meant, since in this patch, the header `new.h` defines both `new` and `delete` operators, and `new.cpp` only implements `delete` operators. It's probably better to rename both the header and the cpp files also.
Ah - we try to keep the header file names in sync with C++ standard header file names: https://eel.is/c++draft/new.syn
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D140078/new/
https://reviews.llvm.org/D140078
More information about the libc-commits
mailing list