[libc-commits] [PATCH] D113061: [libc][NFC] rename str_conv_utils to str_to_int

Michael Jones via Phabricator via libc-commits libc-commits at lists.llvm.org
Tue Nov 2 14:53:05 PDT 2021


michaelrj created this revision.
michaelrj added reviewers: sivachandra, lntue.
Herald added subscribers: libc-commits, ecnelises, tschuett, mgorny.
Herald added a project: libc-project.
michaelrj requested review of this revision.

rename str_conv_utils to str_to_int to be more in line with
str_to_float.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D113061

Files:
  libc/src/__support/CMakeLists.txt
  libc/src/__support/detailed_powers_of_ten.h
  libc/src/__support/high_precision_decimal.h
  libc/src/__support/str_conv_utils.h
  libc/src/__support/str_to_float.h
  libc/src/__support/str_to_int.h
  libc/src/inttypes/CMakeLists.txt
  libc/src/inttypes/strtoimax.cpp
  libc/src/inttypes/strtoumax.cpp
  libc/src/stdlib/CMakeLists.txt
  libc/src/stdlib/atoi.cpp
  libc/src/stdlib/atol.cpp
  libc/src/stdlib/atoll.cpp
  libc/src/stdlib/strtol.cpp
  libc/src/stdlib/strtoll.cpp
  libc/src/stdlib/strtoul.cpp
  libc/src/stdlib/strtoull.cpp
  libc/test/src/__support/CMakeLists.txt

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D113061.384246.patch
Type: text/x-patch
Size: 9043 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libc-commits/attachments/20211102/204a3a1b/attachment.bin>


More information about the libc-commits mailing list