[libc-commits] [PATCH] D99686: [libc] Introduces asctime, asctime_r to LLVM libc, based on C99/C2X/Single Unix Sp.
Siva Chandra via Phabricator via libc-commits
libc-commits at lists.llvm.org
Mon Apr 26 23:18:11 PDT 2021
sivachandra accepted this revision.
sivachandra added a comment.
This revision is now accepted and ready to land.
Sorry for the long delay. I have a nitty comment inline. Also, can you please change the way the subject line is written: Instead of "Introduces asctime, asctime_r to LLVM libc, based on C99/C2X/Single Unix Sp.", can you change it to, "Introduce asctime, asctime_r to LLVM libc". Change the rest of the description in a similar way.
================
Comment at: libc/src/time/time_utils.h:78
+
+static inline char *asctime_internal(const struct tm *timeptr, char *buffer,
+ size_t bufferLength) {
----------------
Nit: Should this function name have the `_internal` suffix? It is already in an internal namespace `time_utils`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99686/new/
https://reviews.llvm.org/D99686
More information about the libc-commits
mailing list