[flang-commits] [PATCH] D142475: [flang][hlfir] Add hlfir.copy_in and hlfir.copy_out codegen to FIR.

Slava Zakharin via Phabricator via flang-commits flang-commits at lists.llvm.org
Tue Jan 24 13:11:15 PST 2023


vzakhari accepted this revision.
vzakhari added inline comments.


================
Comment at: flang/lib/Optimizer/HLFIR/Transforms/ConvertToFIR.cpp:159
+                  genHeapTempFromSourceBox(loc, builder, inputVariable);
+              // Get rid of allocatable flag in the fir.box.
+              temp = builder.create<fir::ReboxOp>(loc, resultAddrType, temp,
----------------
nit: maybe rename `genHeapTempFromSourceBox` to `genAllocatableTempFromSourceBox` so that it is clear that it returns a box with the allocatable flag set (and we need to reset it afterwards).  I think `Allocatable` always implies `Heap`, so such naming should be more telling.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D142475/new/

https://reviews.llvm.org/D142475



More information about the flang-commits mailing list