[flang-commits] [PATCH] D123378: [flang][NFC] rename isAbsent to isStaticallyAbsent in IntrinsicCall.cpp
Jean Perier via Phabricator via flang-commits
flang-commits at lists.llvm.org
Fri Apr 8 03:58:36 PDT 2022
jeanPerier created this revision.
jeanPerier added reviewers: clementval, schweitz.
jeanPerier added a project: Flang.
Herald added subscribers: mehdi_amini, jdoerfert.
Herald added a project: All.
jeanPerier requested review of this revision.
isAbsent/isPresent helpers only give information about static presence
of intrinsic arguments. Many intrinsic arguments optionality is dynamic
(an absent dummy can legally be passed to these intrinsics). This
requires a different handling (like `handleDynamicOptional`).
Rename the helpers to avoid misleading coder/reader into thinking all
optionality cases are covered by them.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D123378
Files:
flang/lib/Lower/IntrinsicCall.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D123378.421485.patch
Type: text/x-patch
Size: 14492 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/flang-commits/attachments/20220408/c552992c/attachment.bin>
More information about the flang-commits
mailing list