[flang-commits] [PATCH] D90324: [Flang][OpenMP][NFC][1/2] Reorder OmpStructureChecker and simplify it.

sameeran joshi via Phabricator via flang-commits flang-commits at lists.llvm.org
Thu Oct 29 03:04:43 PDT 2020


sameeranjoshi added a comment.

>> Makes seperation between constructs, directives and clauses(sub classes are seperated).
>
> Is this change in this patch?

Yes, the file has

1. Constructs and directives at the beginning.
2. Clauses in the later half. The clauses are themselves divided as
  1. First half has clauses which are inside `OmpClause`.
  2. Second half for clauses which have a special node in parse-tree.h. e.g `OmpMemoryOrderClause` and similar ones might come here.

Before this patch they were somewhat mixed in the file.



================
Comment at: flang/lib/Semantics/check-omp-structure.cpp:21
+
+#define CHECK_REQ_CONSTANT_SCALAR_INT_CLAUSE(X, Y) \
+  void OmpStructureChecker::Enter(const parser::OmpClause::X &c) { \
----------------
kiranchandramohan wrote:
> The name is a bit misleading since it does CheckAllowed also.
I see `CheckAllowed` used at all places, hence that is assumed as that is necessary.
`CHECK_REQ_SCALAR_INT_CLAUSE` is as well shared with `AccStructureChecker`.
Do you have a better suggestion here?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D90324/new/

https://reviews.llvm.org/D90324



More information about the flang-commits mailing list