[cfe-users] Simple code refuses to compile ...

Mayuresh Kathe mayuresh at kathe.in
Wed Aug 5 03:51:41 PDT 2015

On 2015-08-05 03:40 PM, Kim Gräsman wrote:
> On Wed, Aug 5, 2015 at 12:00 PM, Mayuresh Kathe <mayuresh at kathe.in> 
> wrote:
>> Okay, did some hunting and reading, looks like Microsoft has something
>> called "Microsoft SDK for Windows 7".
>> That contains the linker and a bunch of other tools.
>> Thanks for that tip about Visual C++ Express, it showed me what else 
>> could
>> be possible. :)
> Cool. I hope it works, I'm not sure how Clang searches for the tools,
> but you can probably figure that out from the source code at:
> http://clang.llvm.org/doxygen/Tools_8cpp_source.html#l08770

Alright, it worked! but only partially, i.e. link.exe when executed from 
within the "Windows SDK 7.1 Command Prompt" works just fine, but not 
from any other console, not even after adding in the path to the SDK to 
the environment variable.
And, for the life of me, I just can't find "LINK.EXE" anywhere on the 
system, but, open up the "Windows SDK 7.1 Command Prompt" and execute 
it, and bam, it just works.

So, I tried running "clang.exe" from within the "Windows SDK 7.1 Command 
Prompt" but it gave the same old error message (below);
clang.exe: error: unable to execute command: program not executable
clang.exe: error: linker command failed with exit code 1 (use -v to see 

After all this, I am quite tempted to be patient till the moment I get 
to return to my preferred system, i.e. FreeBSD.  :)


More information about the cfe-users mailing list