[cfe-users] Simple code refuses to compile ...

Mayuresh Kathe mayuresh at kathe.in
Wed Aug 5 02:24:02 PDT 2015

Hi Kim,

On 2015-08-05 02:38 PM, Kim Gräsman wrote:
> Hi Mayuresh,
> On Tue, Aug 4, 2015 at 1:01 PM, Mayuresh Kathe <mayuresh at kathe.in> 
> wrote:
>> I have installed LLVM-3.8.0-r243265-win64 for my Windows 7 
>> Professional
>> 64-bit and tried to compile a simple program called "test.c" (below);
>> int main(void) {
>>     return 0;
>> }
>> The command issued to compile it was; "clang.exe .\test.c" (without 
>> quotes).
>> The error message(s) thrown back are;
>> clang.exe: error: unable to execute command: program not executable
>> clang.exe: error: linker command failed with exit code 1 (use -v to 
>> see
>> invocation)
> Assuming you're not using MinGW/Cygwin, the Clang driver is looking
> for Visual Studio's linker, LINK.EXE to generate an executable for the
> program.
> Do you have Visual Studio installed? Which version? Have you tried
> `-v` as suggested to see what Clang is trying to do?

No, I am not using MinGW/Cygwin, neither do I have Visual Studio 
I tried the '-v' to see what happens (as suggested), and it threw back a 
whole lot of information which I could not understand.

Is there any way to install "only" LINK.EXE?
If yes, any particular place where I could look for the installable? 


More information about the cfe-users mailing list