[cfe-users] Clang Plugin issue

Jordan Rose jordan_rose at apple.com
Mon Feb 24 09:26:44 PST 2014

Xcode's build of Clang does not support plugins—the symbols have been stripped. You'll have to use your own Clang for that. Sorry!


On Feb 23, 2014, at 0:37 , AlexDenisov <1101.debian at gmail.com> wrote:

> Hi, guys.
> I have an issue with Clang Plugin, it’s pretty simple:
> I want to use plugin within Xcode (for diagnostics purposes), but I can't run plugin with 'system’ clang, it says 'error: unable to find plugin plugin_name’. 
> So question is: can I use clang plugin from Xcode without patching clang?
> I’ve tried my custom plugin, and tried example from repo (print-fns), but have no luck.
> system clang:
> Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
> Target: x86_64-apple-darwin13.0.0
> Thread model: posix
> clang built from source:
> clang version 3.3.1 
> Target: x86_64-apple-darwin13.0.0
> Thread model: posix
> -- 
> Alex Denisov
> https://github.com/AlexDenisov
> Software Engineer at http://railsware.com/
> _______________________________________________
> cfe-users mailing list
> cfe-users at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-users/attachments/20140224/cf446319/attachment.html>

More information about the cfe-users mailing list