[cfe-dev] clang built from source in Mac OSX 10.14 with apple-clang/Xcode missing stdlib from include search path

Jens Jorgensen via cfe-dev cfe-dev at lists.llvm.org
Tue Feb 4 04:01:35 PST 2020

Regrettably it seems that others do not see this as a legitimate bug
:-(. I'm happy to create a ticket, but as a noob to cfe-dev I hit the
mailing list first to test the waters and the reaction didn't seem to
indicate that anyone else regarded it as something that needed fixing.
I'm with you though, I regard this as straight-up broken: ending up with
a compiler that doesn't know where it's standard library is may be a
valid compiler but not a generally useful one.

On 2/4/20 7:59 AM, Sean McBride wrote:
> Jens,
> I've finally tried your patch (against current master), and it indeed solves the problem for me.
> Is there a ticket in bugzilla for this?  I feel it should be a 10.0.0 release blocker.
> Cheers,
> Sean
> On Wed, 11 Dec 2019 11:09:31 +0800, Jens Jorgensen said:
>> Apply my patch and build like :
>> cmake -DLLVM_ENABLE_PROJECTS=clang -G "Unix Makefiles"
>> -DCLANG_XCODE_TOOLCHAIN_ROOT=/Applications/Xcode.app/Contents/Developer/
>> Toolchains/XcodeDefault.xctoolchain
>> ../llvm-project/llvm
>> On 12/10/19 7:45 AM, Sean McBride wrote:
>>> On Wed, 25 Sep 2019 14:49:57 +0200, Hans Wennborg via cfe-dev said:
>>>> I'm always confused when trying to get locally-built Clang to find
>>>> stdlib headers on my Mac.
>>>> Last time, after upgrading to Mojave, following the TL;DR advice from
>>>> this answer made it work for me: https://stackoverflow.com/a/52530212
>>> Seems that advice is obsolete. :(  Nothing else I found online worked
>> either.
>>>> It would certainly be nice if this could somehow work out of the box.
>>> Until then, anyone know how to make one's own build of clang find C++
>> headers on macOS?
>>> Thanks,
>>> Sean
>> -- 
>> Jens B. Jorgensen
>> jbj1 at ultraemail.net
Jens B. Jorgensen
jbj1 at ultraemail.net

More information about the cfe-dev mailing list