[cfe-dev] clang built from source in Mac OSX 10.14 with apple-clang/Xcode missing stdlib from include search path

Arthur O'Dwyer via cfe-dev cfe-dev at lists.llvm.org
Tue Dec 10 05:44:22 PST 2019

On Mon, Dec 9, 2019 at 6:45 PM Sean McBride via cfe-dev <
cfe-dev at lists.llvm.org> wrote:

> On Wed, 25 Sep 2019 14:49:57 +0200, Hans Wennborg via cfe-dev said:
> >I'm always confused when trying to get locally-built Clang to find
> >stdlib headers on my Mac.
> >
> >Last time, after upgrading to Mojave, following the TL;DR advice from
> >this answer made it work for me: https://stackoverflow.com/a/52530212
> Seems that advice is obsolete. :(  Nothing else I found online worked
> either.
> >It would certainly be nice if this could somehow work out of the box.
> Until then, anyone know how to make one's own build of clang find C++
> headers on macOS?

Just replying to say that, BEFORE the move to the monorepo, I never had any
trouble with this checklist:
AFTER the move to the monorepo, I updated my blog post with something that
I thought had worked for me, but it doesn't seem to work really, and I have
not had time (or probably the ability) to figure out what's wrong. It
appears that essentially, libc++ can no longer be built with OSX's native
compiler, and Clang itself can't be built without libc++.
That is, as of 2019-12-10, the instructions here do not actually work for
me: https://quuxplusone.github.io/blog/2019/11/09/llvm-from-scratch/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20191210/554bdf55/attachment.html>

More information about the cfe-dev mailing list