[cfe-dev] Can't exec "clang++" Problem

凌欢 linghuan713 at 126.com
Wed May 8 19:45:37 PDT 2013

Hi, Jordan:
The value of "echo $xcode_path" is something like this:
/Applications/xcode4.5.2_sdk6.0/Contents/Developer/usr/bin/xcodebuild (absolute path)
and my scan-build is upgraded to checker-274.
Inclosed zip file is the scan script and the scan log.
Thanks Jordan.:)

Howard Ling
E-mail:    linghuan713 at 126.com
At 2013-05-08 09:42:05,"Jordan Rose" <jordan_rose at apple.com> wrote:

I'm really not sure where to go from here. This works for me on OS X 10.8 with Xcode 4.6:

~clang/tools/scan-build/scan-build --use-analyzer ~clang/build/bin/Release/clang ~L/Applications/Xcode4.6.app/Contents/Developer/usr/bin/xcodebuild

(where ~clang and ~L are shell directory aliases)

The account I'm on doesn't have a certificate installed, so I built for the simulator instead.

The one thing I can think of (with the patch applied) is that $xcode_path doesn't actually expand to an executable named "xcodebuild" but rather a wrapper script or symlink around xcodebuild.

Can you send me a full transcript of your scan-build invocation and everything the 4.6 xcodebuild spits back out? The results of "echo $xcode_path" would help too.

(You said checker-274, right?)

On May 2, 2013, at 20:02 , 凌欢 <linghuan713 at 126.com> wrote:

Hi, All:
Has any update for thie case?
Thank you.
Howard Ling
E-mail:    linghuan713 at 126.com
At 2013-05-02 09:40:38,"凌欢" <linghuan713 at 126.com> wrote:

hi, Jordan:
I use the following two xcode versions: 

/Applications/xcode4.6_sdk6.1/Contents/Developer/usr/bin/xcodebuild -version
Xcode 4.6
Build version 4H127

$ /Applications/Xcode60.app/Contents/Developer/usr/bin/xcodebuild -version
Xcode 4.5
Build version 4G144l

Two xcode version report the same error.


Howard Ling

At 2013-04-30 06:22:19,"Jordan Rose" <jordan_rose at apple.com> wrote:

Hm. What do you get from $xcode_path -version? That's what scan-build is checking for.

Sorry for the slowness of remote-debugging.

On Apr 28, 2013, at 3:51 , 凌欢 <linghuan713 at 126.com> wrote:

hi, jordan:
After applyed the path ,the same error is still reported .
Sorry for my delay response :) .

Howard Ling
At 2013-04-26 01:55:21,"Jordan Rose" <jordan_rose at apple.com> wrote:

Aha, scan-build currently uses the system xcodebuild to detect the installed version, not the one you specify on the command line. Does this patch clear things up, Howard?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20130509/9638efc3/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: scan.zip
Type: application/x-zip-compressed
Size: 88644 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20130509/9638efc3/attachment.bin>

More information about the cfe-dev mailing list