[cfe-dev] Can't exec "clang++" Problem

凌欢 linghuan713 at 126.com
Wed May 1 18:40:38 PDT 2013

hi, Jordan:
I use the following two xcode versions: 

/Applications/xcode4.6_sdk6.1/Contents/Developer/usr/bin/xcodebuild -version
Xcode 4.6
Build version 4H127

$ /Applications/Xcode60.app/Contents/Developer/usr/bin/xcodebuild -version
Xcode 4.5
Build version 4G144l

Two xcode version report the same error.


Howard Ling

At 2013-04-30 06:22:19,"Jordan Rose" <jordan_rose at apple.com> wrote:

Hm. What do you get from $xcode_path -version? That's what scan-build is checking for.

Sorry for the slowness of remote-debugging.

On Apr 28, 2013, at 3:51 , 凌欢 <linghuan713 at 126.com> wrote:

hi, jordan:
After applyed the path ,the same error is still reported .
Sorry for my delay response :) .

Howard Ling
At 2013-04-26 01:55:21,"Jordan Rose" <jordan_rose at apple.com> wrote:

Aha, scan-build currently uses the system xcodebuild to detect the installed version, not the one you specify on the command line. Does this patch clear things up, Howard?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20130502/22f394d2/attachment.html>

More information about the cfe-dev mailing list