[cfe-dev] [LLVMdev] RFC: Codifying (but not formalizing) the optimization levels in LLVM and Clang

Chandler Carruth chandlerc at google.com
Mon Jan 14 14:52:43 PST 2013


On Mon, Jan 14, 2013 at 1:46 PM, Kaelyn Uhrain <rikka at google.com> wrote:

> On Mon, Jan 14, 2013 at 1:30 PM, <dag at cray.com> wrote:
>
>> Chandler Carruth <chandlerc at gmail.com> writes:
>>
>> > minsizeopt
>> > sizeopt
>> > quickopt
>> > opt
>> > maxopt
>>
>> I prefer being consistent and putting "opt" at the end.
>>
>> I would still like something other than "opt" for the fourth one.  "opt"
>> seems too generic given the other levels.
>>
>
> I agree that having just "opt" seems too generic in comparison. Maybe
> something like "stdopt" (or even the longer "balancedopt") since it
> corresponds to -O2 and is intended to represent a good optimization level
> for most cases with a balance of compile time, space, and runtime
> efficiency.
>

I don't like a qualifier because all the qualifiers I tried don't really
add meaning. I don't see why 'opt' isn't the right name, as I think this
should be the baseline default for any "please optimize my code" request
that isn't more specific.

We could add 'balanced', but balanced between what? It isn't clear.

We could call it 'good', 'basic', 'std', or 'default'; but none seem to
really add information.


>
> - Kaelyn
>
> _______________________________________________
> cfe-dev mailing list
> cfe-dev at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20130114/83d4e48f/attachment.html>


More information about the cfe-dev mailing list