[cfe-dev] llvm and clang: trying to "cmake" a "Visual Studio 10"

Nikola Smiljanic popizdeh at gmail.com
Fri Apr 5 14:27:03 PDT 2013

OK that is strange. And what happens if you call cl from your command

I also noticed that you're using the same directory for source and build,
this shouldn't make a difference but we generally build out of tree so the
command should look like:

M:\BuildDirectory> "F:\Program Files\CMake 2.8\bin\cmake" -G "Visual Studio
10" ../CheckoutLLVM

Mingw should also work, just generate the makefiles and you should be ready
to go. There were some problems with the 4.7 release, I'm not sure if that
was fixed but 4.6.2 used to work just fine.

On Fri, Apr 5, 2013 at 11:29 PM, Andre Mikulec <andre_mikulec at hotmail.com>wrote:

> "
> From: Nikola Smiljanic <popizdeh at gmail.com>
> I'd say that CMake is unable to detect you Visual Studio, and I'm not sure
> what mechanism they use to do that. But you could try running your command
> from the Visual Studio Tools Command Prompt.
> "
> Hmm,
> O.K., I just tried that. ... Exact same errors.
> Hmm, I only have Visual Studio 2010 Express.  Usually that does not make
> difference!?
> A couple weeks agon, I compiled BLAS and LAPACK from netlib with just the
> MinGW32 tools and Cmake and that worked fine.
> Does anyone have any idea whether or not I can compile Clang with MinGW32
> tools and Cmake?
> Anyone tried it?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20130406/0b074c32/attachment.html>

More information about the cfe-dev mailing list