[cfe-dev] Heads up, renaming attempt #2!

Craig Topper craig.topper at gmail.com
Fri Dec 21 17:02:04 PST 2012


On Fri, Dec 21, 2012 at 2:22 PM, Chandler Carruth <chandlerc at gmail.com>wrote:

>
>
>
> On Fri, Dec 21, 2012 at 2:01 PM, Richard Smith <richard at metafoo.co.uk>wrote:
>
>> On Fri, Dec 21, 2012 at 1:43 PM, Chandler Carruth <chandlerc at gmail.com>
>> wrote:
>> > On Fri, Dec 21, 2012 at 1:38 PM, John McCall <rjmccall at apple.com>
>> wrote:
>> >>
>> >> On Dec 21, 2012, at 1:18 PM, Chandler Carruth <chandlerc at gmail.com>
>> wrote:
>> >>
>> >> So, last time I tried, I needed a bit more tooling in place to do the
>> >> renaming sanely. =] That's taken care of, and so I'm hoping to do the
>> >> renaming from 'clang/lib/CodeGen/...' to 'clang/lib/IRGen/...' over the
>> >> holidays (hopefully minimal patches outstanding).
>> >>
>> >> I'm also going to try to systematically clean up the naming of files
>> and
>> >> classes.
>> >>
>> >> The current leading strategy for files:
>> >>
>> >>   lib/CodeGen/CGCall.cpp -> lib/IRGen/Call.cpp
>> >>   lib/CodeGen/CodeGenFunction.cpp -> lib/IRGen/Function.cpp
>> >>
>> >> The current leading strategy for classes:
>> >>
>> >>   clang::CGFoo -> clang::irgen::Foo
>> >>   clang::CodeGenBar -> clang::irgen::Bar
>> >>
>> >> I'm asking Doug and John to paint this bikeshed so that we don't just
>> go
>> >> around in circles endlessly.
>> >>
>> >>
>> >> I really like having a prefix on file names so that they aren't
>> >> immediately confusable — visually, by IDEs, by C-x b, etc. — with
>> files from
>> >> other parts of the compiler.  For example, I think it would be a real
>> loss
>> >> if there were three Decl.cpp files in clang: one in AST, one in Sema,
>> and
>> >> one in IRGen.
>> >
>> >
>> > Sure.
>> >
>> >>
>> >>
>> >> For lack of a better idea, let's go with replacing everything that's
>> >> "CodeGen" with "IRGen" and "CG" with "IR".  "IR" has a pretty
>> unambiguous
>> >> meaning in the context of LLVM.
>> >
>> >
>> > Can we pick just one prefix and have everything use that? Seems a great
>> > opportunity to no longer wonder "is it CGFunction or CodeGenFunction?"
>> >
>> > Should the prefix apply just to the files? 'clang::irgen::IRGenFunction'
>> > seems needlessly redundant, but if that's your preferred shade of
>> bikeshed,
>> > I will make it so. ;]
>>
>> I find having the prefix in the identifier to be very useful for
>> grepability of the code.
>>
>
> I actually agree, but then why bother with the namespace? I could get rid
> of that instead as the unnecessary disambiguation....
>
> But anyways, I don't really care, I just don't understand. =] Carrying on
> with the plan with John's bikeshed color.
>

llvm itself already has a Function.cpp so renaming
CGFunction.cpp->Function.cpp would make that name ambiguous for things like
setting line number breakpoints in gdb.


>
> _______________________________________________
> cfe-dev mailing list
> cfe-dev at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-dev
>
>


-- 
~Craig
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20121221/b5ec056c/attachment.html>


More information about the cfe-dev mailing list