[cfe-dev] Error trying to build libc++abi, unknown type: _Unwind_Exception

Dan Eloff dan.eloff at gmail.com
Fri Apr 20 13:02:35 PDT 2012

Thanks Howard,

I can now build libcxxabi.

However, I can't link it "/usr/bin/ld: cannot find -lc++" (verbose
output below) which is the same error I get trying to compile a hello
world with libc++ and the reason I tried building libcxxabi in the
first place :S

I've spent hours searching about this on google and trying things, but
so far I've made no progress.


clang version 3.1 (trunk 154706)
Target: x86_64-unknown-linux-gnu
Thread model: posix
clang: warning: argument unused during compilation: '-nodefaultlibs'
 "/usr/bin/ld" -z relro --hash-style=gnu --build-id --eh-frame-hdr -m
elf_x86_64 -shared -o libc++abi.so.1.0
-L/lib/x86_64-linux-gnu -L/lib/../lib64 -L/usr/lib/x86_64-linux-gnu
-L/usr/lib/gcc/x86_64-linux-gnu/4.6/../../.. -L/lib -L/usr/lib
abort_message.o cxa_aux_runtime.o cxa_default_handlers.o
cxa_demangle.o cxa_exception.o cxa_exception_storage.o cxa_guard.o
cxa_handlers.o cxa_new_delete.o cxa_personality.o cxa_unexpected.o
cxa_vector.o cxa_virtual.o exception.o private_typeinfo.o stdexcept.o
typeinfo.o -soname libc++abi.so.1 -lpthread -lrt -lc -lc++ -lgcc
--as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s
--no-as-needed /usr/lib/gcc/x86_64-linux-gnu/4.6/crtendS.o
/usr/bin/ld: cannot find -lc++

On Wed, Apr 18, 2012 at 3:56 PM, Howard Hinnant <hhinnant at apple.com> wrote:
> On Apr 18, 2012, at 4:22 PM, Richard Smith wrote:
>> __int128 is a GNU keyword which clang 3.1 supports. This usage of it as an identifier will need to be renamed.
> Thanks, done. Committed revision 155044.
> Howard

More information about the cfe-dev mailing list