[cfe-dev] Problem with libc++

Dix Lorenz dlorenz at medimach.de
Tue Apr 3 11:34:19 PDT 2012

On 03.04.2012, at 20:24, Jean-Daniel Dupas wrote:

> AFAIK, you don't have too use -nostdinc++. clang lookups libc++ headers relatively to its resources directory, so if you install your custom clang in /usr/local/bin, just put them in /usr/local/lib/c++/v1 and it should works.
> Le 3 avr. 2012 à 18:40, Seth Cantrell a écrit :
>> I don't think you want to replace the built-in headers or libraries.
>> Instead you should probably set up the version of libc++ you want
>> somewhere, disable the standard c++ library in your project with
>> -nostdinc++ and then point your Xcode project at the libc++ build you
>> set up using the search path and linker options.
>> On the command line this might look like:
>> clang++ -nostdinc++ -H../libcxx/include -L../libcxx/lib -lc++ main.cpp

I tried Seth' suggestion first, that worked... then I read Jean-Daniels mail, threw most of my changes out again, copied the headers to yet another location... and that works too!

Awesome, many thanks to both of you.

More information about the cfe-dev mailing list