[cfe-dev] Switching terminology from 'instantiation' to 'expansion' for macros?

John McCall rjmccall at apple.com
Fri Jul 8 00:30:04 PDT 2011

On Jul 7, 2011, at 9:10 PM, Chandler Carruth wrote:
> The only other term I've thought about is 'replacement' as that's what the standard uses in most cases. However, for diagnostics and thinking about how the preprocessor works, I actually find 'expansion' much more helpful. However, if others like the C standard's 'replacement' terminology, I'd be down with that. =]

I like 'expansion'.  Specifically, I like "expanded from macro here", or something like that.  I wouldn't try to call out specific cases of where the text came from;  there's a lot of value in having a consistent message for these, because users can recognize the shape of a macro-expansion note at a glance without having to actually read it.

It is not worth trying to avoid the name collision with variadic template parameter packs.

Thanks for doing this!


More information about the cfe-dev mailing list