[cfe-dev] Instance variables in implementation error?

Marcel Weiher marcel.weiher at gmail.com
Sun Jul 3 14:33:25 PDT 2011

Hi folks,

I am working on a code-base that for various reasons has instance variables declared in both the @interface and the @implementation section.  Using gcc 4.2, this is OK, but clang in 64 bit aborts with the following error:

[elided] ../../src/Error.m:13:10: error: instance variable is already declared [3]
     BOOL _isExceptional;

Which is true, that is exactly what's happening, it was just OK (if questionable) before.

In 32 bit mode, clang is OK with this, as is gcc 4.2 in both 32 bit and 64 bit mode.  Any way to turn this error off in clang 64 bit mode?

I tried setting the Objective-C language level using the (gcc) flag  '-fobjc-std=objc1' but that doesn't seem to make a difference.  I did a search of the clang pages at   http://clang.llvm.org/docs/UsersManual.html  but the link to "Objective-C language features" is a dead link ( http://clang.llvm.org/docs/UsersManual.html#objc ), as is the C++ link.  The C language features link works.

I also tried to search the code via the error message, but that wasn't too illuminating either.

For now, I can probably get by with using gcc 4.2, but I'd much prefer to use clang.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20110703/06dbabd8/attachment.html>

More information about the cfe-dev mailing list