[cfe-dev] err:ISO C++ forbids declaration of 'PointerUnion4' with no type

Craig Mortensen mortay at apple.com
Mon Sep 14 15:03:04 PDT 2009


I'm running into a compile errors for PointerUnion4 in TemplateName.h

/usr/local/include/clang/AST/TemplateName.h:63:0 ISO C++ forbids  
declaration of 'PointerUnion4' with no type in /usr/local/include/ 

class TemplateName {
   typedef llvm::PointerUnion4<TemplateDecl *, OverloadedFunctionDecl *,
                               QualifiedTemplateName *,
                               DependentTemplateName *> StorageType;

How to I get the compiler to get passed this?  In XCode, I tried using  
both the built clang compiler from the llvm/clang project and the one  
that comes stock with Mac OSX SnowLeopard.  Both gave the same error.

Thanks for your help,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-dev/attachments/20090914/a490f2b4/attachment.html>

More information about the cfe-dev mailing list