[PATCH] D55101: [clang-tidy] Ignore namespaced and C++ member functions in google-objc-function-naming check 🙈
Stephane Moore via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Nov 30 14:27:56 PST 2018
stephanemoore updated this revision to Diff 176206.
stephanemoore marked an inline comment as done.
stephanemoore added a comment.
Re-formatted google-objc-function-naming.mm to LLVM style.
Repository:
rCTE Clang Tools Extra
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55101/new/
https://reviews.llvm.org/D55101
Files:
clang-tidy/google/FunctionNamingCheck.cpp
test/clang-tidy/google-objc-function-naming.mm
Index: test/clang-tidy/google-objc-function-naming.mm
===================================================================
--- /dev/null
+++ test/clang-tidy/google-objc-function-naming.mm
@@ -0,0 +1,30 @@
+// RUN: %check_clang_tidy %s google-objc-function-naming %t
+
+void printSomething() {}
+// CHECK-MESSAGES: :[[@LINE-1]]:6: warning: function name 'printSomething' not
+// using function naming conventions described by Google Objective-C style guide
+
+void PrintSomething() {}
+// CHECK-MESSAGES: :[[@LINE-1]]:6: warning: function name 'PrintSomething' not
+// using function naming conventions described by Google Objective-C style guide
+
+void ABCBad_Name() {}
+// CHECK-MESSAGES: :[[@LINE-1]]:6: warning: function name 'ABCBad_Name' not
+// using function naming conventions described by Google Objective-C style guide
+
+namespace {
+
+int foo() { return 0; }
+
+}
+
+namespace bar {
+
+int convert() { return 0; }
+
+}
+
+class Baz {
+public:
+ int value() { return 0; }
+};
Index: clang-tidy/google/FunctionNamingCheck.cpp
===================================================================
--- clang-tidy/google/FunctionNamingCheck.cpp
+++ clang-tidy/google/FunctionNamingCheck.cpp
@@ -98,8 +98,9 @@
// main.
Finder->addMatcher(
functionDecl(
- unless(isExpansionInSystemHeader()),
- unless(anyOf(isMain(), matchesName(validFunctionNameRegex(true)),
+ unless(anyOf(isExpansionInSystemHeader(), cxxMethodDecl(),
+ hasAncestor(namespaceDecl()), isMain(),
+ matchesName(validFunctionNameRegex(true)),
allOf(isStaticStorageClass(),
matchesName(validFunctionNameRegex(false))))))
.bind("function"),
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D55101.176206.patch
Type: text/x-patch
Size: 1758 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20181130/46ca7828/attachment.bin>
More information about the cfe-commits
mailing list