[PATCH] D53708: [ASTImporter] Add importer specific lookup
Gabor Marton via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Nov 30 05:42:19 PST 2018
martong updated this revision to Diff 176100.
martong marked 3 inline comments as done.
martong added a comment.
- Address Alexei's comments
- Rename FindDeclsInToCtx to findDeclsInToCtx
- Remove superfluous spaces from stringliterals
- Remove unused header
- Remove empty test
- Return nullptr and FindInDeclListOfDC -> findInDeclListOfDC
- Use SmallSetVector instead of SmallPtrSet
Repository:
rC Clang
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D53708/new/
https://reviews.llvm.org/D53708
Files:
include/clang/AST/ASTImporter.h
include/clang/AST/ASTImporterLookupTable.h
include/clang/CrossTU/CrossTranslationUnit.h
lib/AST/ASTImporter.cpp
lib/AST/ASTImporterLookupTable.cpp
lib/AST/CMakeLists.txt
lib/CrossTU/CrossTranslationUnit.cpp
lib/Frontend/ASTMerge.cpp
unittests/AST/ASTImporterTest.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D53708.176100.patch
Type: text/x-patch
Size: 53849 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20181130/a33a29ec/attachment-0001.bin>
More information about the cfe-commits
mailing list