[PATCH] D54691: [FileManager] getFile(open=true) after getFile(open=false) should open the file.

Sam McCall via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Nov 19 02:42:30 PST 2018


sammccall marked 3 inline comments as done.
sammccall added a comment.

In https://reviews.llvm.org/D54691#1302622, @ilya-biryukov wrote:

> Overall LG. The only concerning bit is that the initialization of the `UFE` is now scattered across the function body.
>  Grouping `File` and `DeferredOpen` into a struct or adding a comment that those are initialized separately from the rest of the fields might make it more evident what's going on. WDYT?


I added a comment in getFile() where ~all the UFE fields are initialized that File and DeferredOpen are initialized above.
Added a redundant initialization in getVirtualFile() for clarity.


Repository:
  rC Clang

https://reviews.llvm.org/D54691





More information about the cfe-commits mailing list