[PATCH] D53389: [clangd] Clear the semantic of RefSlab::size.
Haojian Wu via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Oct 18 02:50:17 PDT 2018
hokein created this revision.
hokein added a reviewer: sammccall.
Herald added subscribers: kadircet, arphaman, jkorous, MaskRay, ioeric, ilya-biryukov.
The RefSlab::size can easily cause confusions, it returns the number of
different symbols, rahter than the number of all references.
- rename size to numSymbols to indicate its semantic clearly.
- add numRefs() method and cache it, since calculating it everytime is nontrivial.
- clear misused places.
Repository:
rCTE Clang Tools Extra
https://reviews.llvm.org/D53389
Files:
clangd/index/Background.cpp
clangd/index/FileIndex.cpp
clangd/index/Index.cpp
clangd/index/Index.h
clangd/index/Serialization.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D53389.170059.patch
Type: text/x-patch
Size: 4352 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20181018/602f082b/attachment.bin>
More information about the cfe-commits
mailing list