[PATCH] D50194: LLVM Proto Fuzzer - Run Functions on Suite of Inputs
Kostya Serebryany via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Aug 3 14:25:43 PDT 2018
kcc added inline comments.
================
Comment at: clang/tools/clang-fuzzer/handle-llvm/handle_llvm.cpp:128
+void RunFuncOnInputs(LLVMFunc f, int x) {
+ if (x) {
+ for (int i = 0; i < NumArrays; i++)
----------------
looks like code duplication, also strange name for a variable: 'x'.
Can't we just have one loop here and pass OptArrays/UnoptArrays as the parameter?
================
Comment at: clang/tools/clang-fuzzer/handle-llvm/input_arrays.h:36
+ {1, 1, 2, 3, 2, 3, 0, 11, 10, 0, 7, 5, 3, 1, 18, 18, 18, 18, 0, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18, 18},
+ {0, 0, 2, 5, 4, 0, 2, 13, 12, 11, 0, 8, 6, 4, 2, 0, 20, 20, 20, 20, 0, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20, 20},
+ {1, 1, 0, 1, 6, 2, 4, 1, 14, 13, 12, 0, 9, 7, 5, 3, 1, 22, 22, 22, 22, 22, 0, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22, 22},
----------------
constants are not diverse enough.
Repository:
rC Clang
https://reviews.llvm.org/D50194
More information about the cfe-commits
mailing list