[PATCH] D44996: [clang-format] Ensure ObjC selectors with 0 args are annotated correctly
Jacek Olesiak via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Mar 29 00:59:14 PDT 2018
jolesiak added inline comments.
================
Comment at: unittests/Format/FormatTestObjC.cpp:527
+ // Make sure selectors with 0, 1, or more arguments are not indented
+ // when IndentWrappedFunctionNames is false.
+ verifyFormat("- (aaaaaaaaaaaaaaaaaaaaaaaaaaaaa)\n"
----------------
I know that `Style.IndentWrappedFunctionNames` is false by default, but how about adding
```
Style.IndentWrappedFunctionNames = false;
```
before these `verifyFormat` calls? I feel like that makes it more readable and makes test independent on this `Style` constant.
Repository:
rC Clang
https://reviews.llvm.org/D44996
More information about the cfe-commits
mailing list