[PATCH] D44628: Backport changes from llvm/.clang_tidy to clang/.clang_tidy configs

Ilya Biryukov via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Mar 20 02:38:46 PDT 2018


ilya-biryukov added inline comments.


================
Comment at: .clang-tidy:8
   - key:             readability-identifier-naming.FunctionCase
-    value:           lowerCase
+    value:           camelBack
+  - key:             readability-identifier-naming.MemberCase
----------------
simark wrote:
> In practice, don't we use `CamelCase` for functions?
No, functions should be `camelCase`. I've seen some violations, but [[https://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly|the style guide]] seems to be clear:

> Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name **should be camel case, and start with a lower case letter** (e.g. openFile() or isFoo()).




Repository:
  rC Clang

https://reviews.llvm.org/D44628





More information about the cfe-commits mailing list