[PATCH] D42660: [PR32482] Fix bitfield layout for -mms-bitfield and pragma pack

John McCall via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Jan 29 14:34:35 PST 2018


rjmccall added inline comments.


================
Comment at: lib/AST/RecordLayoutBuilder.cpp:1564
   unsigned MaxFieldAlignmentInBits = Context.toBits(MaxFieldAlignment);
+  unsigned RecordFieldAlign = FieldAlign;
   if (!MaxFieldAlignment.isZero() && FieldSize) {
----------------
I think naming this 'FieldAlignForRecord' would be clearer.

Other this LGTM.


Repository:
  rC Clang

https://reviews.llvm.org/D42660





More information about the cfe-commits mailing list