[PATCH] D37014: [clang-tidy] Add a checker to remove useless intermediate variables before return statements with comparisons
Tristan Bourvon via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Sun Jan 28 11:12:45 PST 2018
tbourvon marked an inline comment as done.
tbourvon added inline comments.
================
Comment at: test/clang-tidy/readability-unnecessary-intermediate-var.cpp:206
+ auto test = 1; // Test
+#ifdef INTERMITTENT_MACRO
+ return (test == 1);
----------------
lebedev.ri wrote:
> Tests are nice :)
> But please, add the test with assert-like macro..
Sorry, I'm not sure I understand what kind of test you are suggesting... Could you give me a short example?
Repository:
rCTE Clang Tools Extra
https://reviews.llvm.org/D37014
More information about the cfe-commits
mailing list