[PATCH] D35109: [Analyzer] SValBuilder Comparison Rearrangement
Alexander Shaposhnikov via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Aug 9 23:19:02 PDT 2017
alexshap added inline comments.
================
Comment at: lib/StaticAnalyzer/Core/SimpleSValBuilder.cpp:561
+ // manager to handle these comparisons.
+ if (BinaryOperator::isComparisonOp(op) &&
+ rhs.getSubKind() == nonloc::SymbolValKind) {
----------------
some thoughts - evalBinOpNN is already pretty gigantic (300+ locs),
imo it might be useful to reorganize the code (at least the newly added one) to improve readability.
i.e. since a partial case (isSignedIntegerOrEnumerationType) is under consideration here,
probably it would be good (where it's reasonable) to move some details into a helper function/method.
https://reviews.llvm.org/D35109
More information about the cfe-commits
mailing list