[PATCH] D35961: [llvm] Update MachOObjectFile::exports interface
Saleem Abdulrasool via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Jul 27 21:50:22 PDT 2017
compnerd added a comment.
Does anyone use the overload with the `O` for `exports` with `nullptr` instead of `this`? If not, we could just inline `this` throughout.
================
Comment at: tools/llvm-nm/llvm-nm.cpp:1230
Error Err = Error::success();
- for (const llvm::object::ExportEntry &Entry : MachO->exports(Err,
- MachO)) {
+ for (const llvm::object::ExportEntry &Entry : MachO->exports(Err)) {
bool found = false;
----------------
I think that using `auto` here instead of `llvm::object:ExportEntry` is better for readability.
================
Comment at: tools/llvm-objdump/MachODump.cpp:9406
Error Err = Error::success();
- for (const llvm::object::ExportEntry &Entry : Obj->exports(Err, Obj)) {
+ for (const llvm::object::ExportEntry &Entry : Obj->exports(Err)) {
uint64_t Flags = Entry.flags();
----------------
Similar.
Repository:
rL LLVM
https://reviews.llvm.org/D35961
More information about the cfe-commits
mailing list