[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores
Alexander Kornienko via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Apr 26 06:37:10 PDT 2017
alexfh accepted this revision.
alexfh added a comment.
This revision is now accepted and ready to land.
LG with a nit.
================
Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:378
+ StringRef Mid = StringRef(Fixed).trim("_");
+ if (Mid.size() == 0)
+ Mid = "_";
----------------
Mid.empty()
https://reviews.llvm.org/D32333
More information about the cfe-commits
mailing list