[PATCH] D31176: [clang-rename] Support renaming qualified symbol
Eric Liu via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Mar 30 05:14:35 PDT 2017
ioeric accepted this revision.
ioeric added a comment.
This revision is now accepted and ready to land.
Lg with a few nits.
================
Comment at: clang-rename/RenamingAction.cpp:104
+ USRList[I], NewNames[I], Context.getTranslationUnitDecl());
+ for (const auto AtomicChange : AtomicChanges) {
+ for (const auto &Replace : AtomicChange.getReplacements()) {
----------------
Maybe add a `FIXME` to fully replace this with `AtomicChange`s in the future?
================
Comment at: clang-rename/USRLocFinder.h:38
+std::vector<tooling::AtomicChange>
+createAtomicChanges(llvm::ArrayRef<std::string> USRs, llvm::StringRef NewName,
+ Decl *TranslationUnitDecl);
----------------
I'd name this `createRenameAtomicChanges` for clarity.
https://reviews.llvm.org/D31176
More information about the cfe-commits
mailing list