[PATCH] D28266: Transparent_union attribute should be possible in front of union (rework)

Aaron Ballman via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Feb 28 12:44:22 PST 2017


aaron.ballman accepted this revision.
aaron.ballman added a comment.
This revision is now accepted and ready to land.

LGTM, with one formatting nit.



================
Comment at: lib/Sema/SemaDeclAttr.cpp:6201
+void Sema::ProcessDeclAttributeDelayed(Decl *D, const AttributeList *AttrList) {
+  for (const AttributeList* l = AttrList; l; l = l->getNext())
+    if (l->getKind() == AttributeList::AT_TransparentUnion) {
----------------
aaron.ballman wrote:
> Nit: the `*` should bind to `l` and `l` should be `L` by our usual naming conventions (but a name better than `L` wouldn't be amiss).
Nit: missing a space before the first `=`. You should run clang-format on the patch to catch this sort of thing.


https://reviews.llvm.org/D28266





More information about the cfe-commits mailing list