[PATCH] D29893: [change-namespace] add an option to dump changed files in YAML.

Haojian Wu via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Feb 13 08:52:48 PST 2017


hokein added inline comments.


================
Comment at: change-namespace/tool/ClangChangeNamespace.cpp:68
+cl::opt<bool>
+    DumpYAML("dump_yaml",
+         cl::desc("Dump new file content in YAML, if specified."),
----------------
`dump_result` maybe a clearer name, which also is consistent with clang-move's.


================
Comment at: change-namespace/tool/ClangChangeNamespace.cpp:137
+
+  for (const auto &File : ChangedFiles) {
     const auto *Entry = FileMgr.getFile(File);
----------------
Is this duplicated as we already have "dump_results" option now?


https://reviews.llvm.org/D29893





More information about the cfe-commits mailing list